Category Archives: Uncategorized

RSTP-Rapid Spanning Tree Protocol

Rapid Spanning Tree Protocol dibuat untuk mengizinkan switch untuk secara cepat bertransisi menjadi kondisi “forwarding state” untuk mencegah delay ketika host terkoneksi ke switch atau ketika topology jaringan berubah. STP membutuhkan 30 sampai 50 detik untuk merespons perubahan topology , dimana RSTP akan merespons perubahan menjadi milli detik.

RSTP Role :

rstp role

RSTP Port State :

rstp port state

Catatan :

Port Fast enable pada access port , akan secara langsung menjadi forwarding state dan port akan langsung menjadi up. Dan jangan digunakan pada Trunk Ports , ini kan menjadi masalah dengan loop switch.

Contoh STP :

stp topology

SW0 Config :

SW0(config)#spanning-tree mode rapid-pvst

SW0(config)#interface range 0/1 – 2

SW0(config-if-range)#spanning-tree portfast

SW0(config-if-range)#no shut

SW0(config-if-range)#end

SW0(config)#wr

SW1 Config :

SW1(config)#spanning-tree mode rapid-pvst

SW1(config)#interface range 0/1 – 2

SW1(config-if-range)#spanning-tree portfast

SW1(config-if-range)#no shut

SW1(config-if-range)#end

SW1(config)#wr

SW2 Config :

SW2(config)#spanning-tree mode rapid-pvst

SW2(config)#interface range 0/1 – 2

SW2(config-if-range)#spanning-tree portfast

SW2(config-if-range)#no shut

SW2(config-if-range)#end

SW2(config)#wr

SW3 Config :

SW3(config)#spanning-tree mode rapid-pvst

SW3(config)#interface range 0/1 – 2

SW3(config-if-range)#spanning-tree portfast

SW3(config-if-range)#no shut

SW3(config-if-range)#end

SW3(config)#wr

SW4 Config :

SW4(config)#spanning-tree mode rapid-pvst

SW4(config)#interface range 0/1 – 2

SW4(config-if-range)#spanning-tree portfast

SW4(config-if-range)#no shut

SW4(config-if-range)#end

SW4(config)#wr

Dan terakhir pada SW1 , kita lakukan perintah sbb :

SW0(config)#spanning-tree vlan 1 root primary

Lihat hasil pada SW0 , dengan perintah sh run , akan terlihat Interface Fa0/1 dan Fa0/2 manjadi portfast.

shrun_sw0

Hasil dari SW1 :

shrun_sw1

Coba check kembali pada sisa switch yang belum di check ( SW2,SW3 dan SW4 ).

 

STP – Spanning Tree Protocol

Spanning Tree Protocol dibuat untuk membatasi kemana switch akan memforward frames , mencegah loop pada redundant switch pada lokal arena network. STP dibuat karena ada beberapa switch yang akan memforward frame pada LAN tanpa adanya intervensi secara langsung.

Ketika STP diaktifkan , STP akan mengijinkan switch untuk mem-block port , yang akan mencegah mereka mem-forward frame jika switch menggunakan redundant link. Pemilihan port yang akan di block dilakukan dengan secara cerdik.

  • STP dibuat agar frame tidak dapat looping secara terus menerus atau tanpa henti.
  • STP membatasi frame dari looping secara terus menerus dengan memeriksa port untuk menentukan apakah port tersebut dalam keadaan terblok. Dan jika dalam keadaan terblok semua traffik akan ditahan dan tidak ada frame yang akan dikirim ke luar dan frame yang masuk pada interface tersebut.

Kenapa kita membutuhkan STP ?

Tanpa STP , Ethernet Frame akan berpotensi untuk looping selamanya. Broadcast storm terjadi ketika frame akan looping secera terus menerus yang akan menyebabkan network menjadi lambat yang akan ber-implikasi pada user dan perangkat yang lain.

Bagaimana STP Bekerja ?

STP memutuskan port mana atau interface yang harus berada pada kondisi “forwarding state” , dengan yang lain atau sisanya akan berkondisi “blocking state”.

Interface yang dalam keadaan Forwarding State akan menerima dan mengirim frame dan yang lain akan dalam kondisi blocking state ( tidak dapat menerima dan mengiriman frame ). STP akan memilih siapa yang akan menjadi “root” jika semua port dalam dalam kondisi “forwarding state”. Dalam pemilihan ini status root ini disebut “root bridge election”.

Sebuah “root bridge election” harus dipilih , root bridge spanning tree adalah yang yang mempunya Bridge ID yang terendah. Bridge ID adalah kombinasi dari priority number dan MAC Address. Default bridge priority adalah 32768 , yang dapat dikonfigurasi pada kelipatan dari 4096. Sebagai contoh bridge ID adalah 32768.0000.1111.2222 , jika switch mempunyai priority yang sama maka yang akan menjadi root bridge adalah yang mempunyai MAC terendah.

Sebagai contoh kasus , jika 2 buah switch mempunya prioroty yang sama yaitu 32768 , kemudian switch 1 mempunyai mac adress 0000.1111.1111 dan switch 2 mempunyai mac address 0000.1111.2222 , maka switch 1 lah yang akan menjadi root bridge karena mempunyai nilai MAC ID yang rendah.

 

Configure Ether Channel

EtherChannel umumnya digunakan oleh Cisco Switch. EtherChannel mengijinkan beberapa physical Ethernet ports untuk dibuat menjadi sebuah logical link. Logical link ini menjadikan EtherChannel sebuah “Fault-Tolerant Link” antar perangkat. EtherChannel ini mengijinkan semua bandwidth yang ada pada port yang dijadikan menjadi logical link menjadi satu. Sebagai contoh , jika masing-masing port yang digunakan adalah 100Mb , maka jika kita gunakan 3 port untuk EtherChannel maka logical link tersebut menjadi 300Mb , dan jika salah satu link tersebut itu rusak EtherChannel masih tetap berjalan menggunakan port yang lain. Untuk itu EtherChannel sangat baik digunakan untuk Mission Critical untuk digunakan sebagai Backbone Link.

EtherChannel Protocol 

Ada 2 Protocol EtherChannel yang bisa digunakan sbb :

1.PAGP : Port Agregation Protocol ( Cisco Proprietary ).

2.LACP : IEEE Standard link untuk Aggregation Protocol

PAGP Mode :

pagp mode

LACP Mode :

lacp mode

Berikut contoh Lab yang bisa dilakukan :

contoh lab

Cara Config sbb :

LACP PortChannel :

Konfigurasi pada Switch 1 :

SW1(config)#interface range fa0/1 – 3

SW1(config-if-range)#switchport mode access

SW1(config-if-range)#switchport access vlan 99

SW1(config-if-range)#channel-protocol lacp

SW1(config-if-range)#channel-group 1 mode active

Untuk pastikan bahwa EtherChannel sudah jadi pada SW1 , jalankan perintah sbb :

SW1#show etherchannel

Channel-group listing:

———————-

Group: 1

———-

Group state = L2

Ports: 3 Maxports = 16

Port-channels: 1 Max Port-channels = 16

Protocol: LACP

Konfigurasi pada Switch 2 :

SW2(config)#interface range fa0/1 – 3

SW2(config-if-range)#switchport mode access

SW2(config-if-range)#switchport access vlan 99

SW2(config-if-range)#channel-protocol lacp

SW2(config-if-range)#channel-group 1 mode passive

Untuk pastikan bahwa EtherChannel sudah jadi pada SW2, jalankan perintah sbb :

SW2#show etherchannel

Channel-group listing:

———————-

Group: 1

———-

Group state = L2

Ports: 3 Maxports = 16

Port-channels: 1 Max Port-channels = 16

Protocol: LACP

Konfigurasi EtherChannel ini hanya mengijinkan pengiriman data melalui Vlan 99 melalui EtherChannel link , untuk memberikan akses pada vlan lain , kita harus konfigurasi Switch menjadi “Port Trunk” , karena diatas kita hanya memberikan switch Access dan hanya mengirimkan data melalui Vlan 99.

PAGP EtherChannel

Konfigurasi pada SW1 :

SW1(config)#interface port-channel 1

“no switchport” digunakan karena kita ingin port channel interface dikonfigure menjadi layer 3 interface , dimana kita bisa langsung konfigurasi ip pada interface tersebut.

SW1(config-if)#no switchport

SW1(config-if)#ip address 192.168.1.1 255.255.255.0

SW1(config-if)#interface range fa 0/1 – 3

SW1(config-if-range)#no switchport

SW1(config-if-range)#no ip address

SW1(config-if-range)#channel-group 1 mode desirable

SW1(config-if-range)#end

Check Config Akhir :

SW1#sh etherchannel

Channel-group listing:

———————-

Group: 1

———-

Group state = L3

Ports: 3 Maxports = 8

Port-channels: 1 Max Portchannels = 1

Protocol: PAGP

Konfigurasi pada SW2 :

SW2(config)#interface port-channel 1

SW2(config-if)#no switchport

SW2(config-if)#ip address 192.168.1.2 255.255.255.0

SW2(config-if)#interface range fa0/1 – 3

SW2(config-if-range)#no shut

SW2(config-if-range)#no switchport

SW2(config-if-range)#no ip address

SW2(config-if-range)#channel-group 1 mode auto

SW2(config-if-range)#end

Check Config Akhir :

SW2#show etherchannel

Channel-group listing:

———————-

Group: 1

———-

Group state = L3

Ports: 3 Maxports = 8

Port-channels: 1 Max Portchannels = 1

Protocol: PAGP

Catatan:

Perintah “no switchport” digunakan untuk merubah interface dari mode layer 2 manjadi mode layer 3.

 

 

 

 

Understanding Active Directory Infrastructure

AD Microsoft technology adalah sebuah distribusi Database yang menyimpan object dengan hirarki dan secara struktural dengan format yang sangat aman.

AD Object biasanya merepresentasikan sebagai Users , Computers , Peripheral Devices , dan Network Services. Masing-masing Object secara unik diidentifikasikan dengan Nama dan Attribut.

Domain , Forest , dan Tree di repsentasikan dengan Division dari AD Infrastructure. AD menggunakan Protocol dan Services seperti dibawah ini :

  • Lightweight Directory Access Protocol (LDAP): Digunakan untuk mengakses Directory Service Data.
  • Kerberos: Merupakan Authentikasi keamanan yang membuktikan Identitas antara user dan server didalam network ( Jaringan ).
  • Domain Name System (DNS): DNS digunakan untuk translasi ( menerjemahkan ) nama Domain ke IP Address.

AD dapat dimanage oleh MMC ( Mirosoft Management ) – mmc.exe

  • Active Directory Administrative Center (dsac.exe): Console ini digunakan untuk management Windows Server directory services.

4.1.png

The Active Directory Administrative Center in Windows Server 2016.

  • Active Directory Users and Computers (dsa.msc): Console ini digunakan untuk management Domain , Trust , dan informasi yang relevan lainya.
  • Active Directory Sites and Services (dssite.msc): Console ini digunakan untuk management replikasi dan services antar site.
  • Active Directory Module for Windows PowerShell: Console ini digunakan untuk management Windows Server directory melalui cmdlets.

Kita dapat mengakses Microsoft Script Center pada : https://technet.microsoft.com/en-us/scriptcenter/bb410849.aspx  dan Power Shell galery pada : https://www.powershellgallery.com/

Site keduanya merupakan repository yang free dan merupakan public domain PowerShell Scripts.

 

 

 

Sophos Lab -Thread Report 2019

Hot off the press, the new SophosLabs Threat Report reveals the three key cybersecurity trends for 2019:
Hand-crafted, targeted attacks are gaining popularity
Attackers are hacking and hiding in plain sight
Mobile and IoT malware is not slowing down
Download the SophosLabs 2019 Threat Report to deep dive into these trends, get detailed SophosLabs analysis of the attack, and understand how best to secure your organization against them.

https://www.sophos.com/en-us/medialibrary/pdfs/technical-papers/sophoslabs-2019-threat-report.pdf

 

HKKI 2018 –

Undangan gratis ke HKKI 2018 ( Hari Kebudayaan Keamanan Informasi 2018 ) , silakan hadir bagi yang ingin datang , acara akan diadakan pada tgl 7 Maret 2018 . Lokasi ada di Grand Ballroom Hotel Kempisky , dekat dengan Grand Indonesia.

Silakan daftar terlebih dahulu di : s.id/1g4R

Salam Informasi.

HKKI 2018

Terkena “Ransomeware” ??

Disadur dari ZDNet.

Terkena Ransome ware , berikut Free Tool Decryption yang dibuat oleh Bitdefender yaitu suatu perusahaan Antivirus Terkemuka dari Eropa Timur tepatnya Rumania.

Korban salah satu keluarga ransomware terbaru – dan yang paling tidak biasa – sekarang dapat memulihkan file mereka tanpa memberikan tuntutan pada penjahat karena alat dekripsi telah dibebaskan secara gratis.

Alat dekripsi ransomware GandCrab telah dirilis sebagai bagian dari inisiatif No More Ransom, menyusul operasi gabungan oleh BitDefender, Kepolisian Rumania, Direktorat Investigasi Teror Terorisme Terorisme (DIICOT) dan Europol.

GandGrab pertama kali muncul pada bulan Januari dan telah mengklaim lebih dari 53.000 korban di seluruh dunia, menjadikannya Europol sebagai “salah satu bentuk ransomware paling agresif sepanjang tahun ini” yang menelan korban dari beberapa ratus dolar sampai beberapa ribu orang.

Varian dari malware penguncian file ini tidak biasa dengan beberapa cara: tidak hanya menyebar melalui penggunaan alat eksploitasi – taktik yang biasanya disediakan untuk orang-orang seperti trojan dan penambang kriptocurrency – ini juga merupakan bentuk pertama dari ransomware pembayaran di Dash. Sebagian besar bentuk ransomware lainnya menuntut uang tebusan dibayarkan di bitcoin atau Monero.

Penyebaran GandGrab juga telah dibantu oleh skema cybercrime-as-a-service yang menawarkan toolkit untuk menggelar uang tebusan dengan imbalan penjahat wannabee yang memberikan potongan asli dari penulis asli.

Tidak diketahui operasi cybercriminal spesifik mana yang berada di belakang GandGrab. Namun, ransomware diiklankan di forum hacking Rusia, dengan para penulis secara eksplisit menginstruksikan mereka yang menjadi bagian dari skema kemitraan untuk tidak menargetkan Rusia atau negara lain di Persemakmuran Negara-negara Merdeka bekas republik Soviet.

GrandCrab Decryptor :

GransCrab_decryptor

Tapi terlepas dari siapa yang bisa mendistribusikan GandCrab, sekarang korban tidak perlu membayar uang tebusan kepada mereka yang ingin menguangkannya, karena alat dekripsi tersedia secara gratis dari portal No More Ransom dan dari Bitdefender.

“Ransomware telah menjadi sapi perah miliaran dolar bagi para pembuat malware, dan GandCrab adalah salah satu penawar tertinggi,” kata Catalin Cosoi, direktur senior unit investigasi dan forensik di BitDefender.

Untuk membantu mencegah jatuh korban ransomware, Bitdefender merekomendasikan data sensitif back-up secara rutin dan mewaspadai lampiran email yang mencurigakan dan tautan berbahaya.

Diluncurkan pada tahun 2016, skema No More Ransom membawa penegak hukum dan industri swasta bersama dalam perang melawan dunia maya dan telah membantu korban korban ransomware untuk mengambil file terenkripsi mereka.

Portal ini tersedia dalam 29 bahasa dan sejak diluncurkan telah menerima lebih dari 1,6 juta dari total 180 negara.

Pelepasan alat dekripsi GandCrab muncul tak lama setelah sebuah operasi yang terkait Europol, Polisi Nasional Belgia dan Lab Kaspersky sebab dikeluarkannya dekripsi gratis.