Category Archives: Networking

Tunnel

Tunnel adalah dimana local devices dapat berkomunikasi dengan remote devices dimana remote devices adalah termasuk local devices juga. Ada banyak tipe/model Tunnel , VPN ( Virtual Private Network ) adalah termasuk Tunnel , GRE ( Generic Routing Encapsulation ) membuat Tunnel , SSH ( Secure Shell ) juga termasuk membuat Tunnel.

GRE ( Generic Routing Encapsulation )

GRE mengijinkan remote network untuk ditampilkan menjadi local network. GRE tidak menawarkan enkripsi tetapi dia memforward broadcast dan multicast. Jika kita menginginkan routing protocol untuk dijalankan atau merubah routing melalui tunnel , anda mungkin membutuhkan GRE Tunnel. GRE Tunnel sering di bundle dengan VPN Tunnel untuk memberikan keuntungan yaitu enkripsi.

VPN ( Virtual Private Network )

VPN tunnel mengijinkan remote network menjadi local network. VPN akan mengenkripsi semua informasi sebelum dikirimkan melalui network , tetapi dia tidak akan memforward multicast dan broadcast packet. Karena itu VPN sering di bundle dengan GRE agar bisa melewatkan routing.

Ada 2 tipe VPN , yaitu : Point to Point dan Remote Access

1.Point to Point , menawarkan konektivitas antara dua remote router , membuat virtual link antara ke dua router tersebut.

2.Remote Access , adalah single user access tunnel antara user dan router , firewall atau VPN concentrator.

Remote access VPN biasanya dibutuhkan client software untuk diinstall pada pc ataupun laptop , dan client berkomunikasi dengan perangkat VPN untuk membuat sebuah personal virtual link.

SSH ( Secure Shell )

SSH adalah sebuah aplikasi client/server yang mengijinkan aplikasi tersebut membuat koneksi ke server dengan aman. Dalam pekerjaan hari-hari biasa digunakan Telnet , tetapi SSH menawarkan enkripsi sebelum data dikirimkan.

GRE Tunnels

 

RSTP-Rapid Spanning Tree Protocol

Rapid Spanning Tree Protocol dibuat untuk mengizinkan switch untuk secara cepat bertransisi menjadi kondisi “forwarding state” untuk mencegah delay ketika host terkoneksi ke switch atau ketika topology jaringan berubah. STP membutuhkan 30 sampai 50 detik untuk merespons perubahan topology , dimana RSTP akan merespons perubahan menjadi milli detik.

RSTP Role :

rstp role

RSTP Port State :

rstp port state

Catatan :

Port Fast enable pada access port , akan secara langsung menjadi forwarding state dan port akan langsung menjadi up. Dan jangan digunakan pada Trunk Ports , ini kan menjadi masalah dengan loop switch.

Contoh STP :

stp topology

SW0 Config :

SW0(config)#spanning-tree mode rapid-pvst

SW0(config)#interface range 0/1 – 2

SW0(config-if-range)#spanning-tree portfast

SW0(config-if-range)#no shut

SW0(config-if-range)#end

SW0(config)#wr

SW1 Config :

SW1(config)#spanning-tree mode rapid-pvst

SW1(config)#interface range 0/1 – 2

SW1(config-if-range)#spanning-tree portfast

SW1(config-if-range)#no shut

SW1(config-if-range)#end

SW1(config)#wr

SW2 Config :

SW2(config)#spanning-tree mode rapid-pvst

SW2(config)#interface range 0/1 – 2

SW2(config-if-range)#spanning-tree portfast

SW2(config-if-range)#no shut

SW2(config-if-range)#end

SW2(config)#wr

SW3 Config :

SW3(config)#spanning-tree mode rapid-pvst

SW3(config)#interface range 0/1 – 2

SW3(config-if-range)#spanning-tree portfast

SW3(config-if-range)#no shut

SW3(config-if-range)#end

SW3(config)#wr

SW4 Config :

SW4(config)#spanning-tree mode rapid-pvst

SW4(config)#interface range 0/1 – 2

SW4(config-if-range)#spanning-tree portfast

SW4(config-if-range)#no shut

SW4(config-if-range)#end

SW4(config)#wr

Dan terakhir pada SW1 , kita lakukan perintah sbb :

SW0(config)#spanning-tree vlan 1 root primary

Lihat hasil pada SW0 , dengan perintah sh run , akan terlihat Interface Fa0/1 dan Fa0/2 manjadi portfast.

shrun_sw0

Hasil dari SW1 :

shrun_sw1

Coba check kembali pada sisa switch yang belum di check ( SW2,SW3 dan SW4 ).

 

STP – Spanning Tree Protocol

Spanning Tree Protocol dibuat untuk membatasi kemana switch akan memforward frames , mencegah loop pada redundant switch pada lokal arena network. STP dibuat karena ada beberapa switch yang akan memforward frame pada LAN tanpa adanya intervensi secara langsung.

Ketika STP diaktifkan , STP akan mengijinkan switch untuk mem-block port , yang akan mencegah mereka mem-forward frame jika switch menggunakan redundant link. Pemilihan port yang akan di block dilakukan dengan secara cerdik.

  • STP dibuat agar frame tidak dapat looping secara terus menerus atau tanpa henti.
  • STP membatasi frame dari looping secara terus menerus dengan memeriksa port untuk menentukan apakah port tersebut dalam keadaan terblok. Dan jika dalam keadaan terblok semua traffik akan ditahan dan tidak ada frame yang akan dikirim ke luar dan frame yang masuk pada interface tersebut.

Kenapa kita membutuhkan STP ?

Tanpa STP , Ethernet Frame akan berpotensi untuk looping selamanya. Broadcast storm terjadi ketika frame akan looping secera terus menerus yang akan menyebabkan network menjadi lambat yang akan ber-implikasi pada user dan perangkat yang lain.

Bagaimana STP Bekerja ?

STP memutuskan port mana atau interface yang harus berada pada kondisi “forwarding state” , dengan yang lain atau sisanya akan berkondisi “blocking state”.

Interface yang dalam keadaan Forwarding State akan menerima dan mengirim frame dan yang lain akan dalam kondisi blocking state ( tidak dapat menerima dan mengiriman frame ). STP akan memilih siapa yang akan menjadi “root” jika semua port dalam dalam kondisi “forwarding state”. Dalam pemilihan ini status root ini disebut “root bridge election”.

Sebuah “root bridge election” harus dipilih , root bridge spanning tree adalah yang yang mempunya Bridge ID yang terendah. Bridge ID adalah kombinasi dari priority number dan MAC Address. Default bridge priority adalah 32768 , yang dapat dikonfigurasi pada kelipatan dari 4096. Sebagai contoh bridge ID adalah 32768.0000.1111.2222 , jika switch mempunyai priority yang sama maka yang akan menjadi root bridge adalah yang mempunyai MAC terendah.

Sebagai contoh kasus , jika 2 buah switch mempunya prioroty yang sama yaitu 32768 , kemudian switch 1 mempunyai mac adress 0000.1111.1111 dan switch 2 mempunyai mac address 0000.1111.2222 , maka switch 1 lah yang akan menjadi root bridge karena mempunyai nilai MAC ID yang rendah.

 

Configure Ether Channel

EtherChannel umumnya digunakan oleh Cisco Switch. EtherChannel mengijinkan beberapa physical Ethernet ports untuk dibuat menjadi sebuah logical link. Logical link ini menjadikan EtherChannel sebuah “Fault-Tolerant Link” antar perangkat. EtherChannel ini mengijinkan semua bandwidth yang ada pada port yang dijadikan menjadi logical link menjadi satu. Sebagai contoh , jika masing-masing port yang digunakan adalah 100Mb , maka jika kita gunakan 3 port untuk EtherChannel maka logical link tersebut menjadi 300Mb , dan jika salah satu link tersebut itu rusak EtherChannel masih tetap berjalan menggunakan port yang lain. Untuk itu EtherChannel sangat baik digunakan untuk Mission Critical untuk digunakan sebagai Backbone Link.

EtherChannel Protocol 

Ada 2 Protocol EtherChannel yang bisa digunakan sbb :

1.PAGP : Port Agregation Protocol ( Cisco Proprietary ).

2.LACP : IEEE Standard link untuk Aggregation Protocol

PAGP Mode :

pagp mode

LACP Mode :

lacp mode

Berikut contoh Lab yang bisa dilakukan :

contoh lab

Cara Config sbb :

LACP PortChannel :

Konfigurasi pada Switch 1 :

SW1(config)#interface range fa0/1 – 3

SW1(config-if-range)#switchport mode access

SW1(config-if-range)#switchport access vlan 99

SW1(config-if-range)#channel-protocol lacp

SW1(config-if-range)#channel-group 1 mode active

Untuk pastikan bahwa EtherChannel sudah jadi pada SW1 , jalankan perintah sbb :

SW1#show etherchannel

Channel-group listing:

———————-

Group: 1

———-

Group state = L2

Ports: 3 Maxports = 16

Port-channels: 1 Max Port-channels = 16

Protocol: LACP

Konfigurasi pada Switch 2 :

SW2(config)#interface range fa0/1 – 3

SW2(config-if-range)#switchport mode access

SW2(config-if-range)#switchport access vlan 99

SW2(config-if-range)#channel-protocol lacp

SW2(config-if-range)#channel-group 1 mode passive

Untuk pastikan bahwa EtherChannel sudah jadi pada SW2, jalankan perintah sbb :

SW2#show etherchannel

Channel-group listing:

———————-

Group: 1

———-

Group state = L2

Ports: 3 Maxports = 16

Port-channels: 1 Max Port-channels = 16

Protocol: LACP

Konfigurasi EtherChannel ini hanya mengijinkan pengiriman data melalui Vlan 99 melalui EtherChannel link , untuk memberikan akses pada vlan lain , kita harus konfigurasi Switch menjadi “Port Trunk” , karena diatas kita hanya memberikan switch Access dan hanya mengirimkan data melalui Vlan 99.

PAGP EtherChannel

Konfigurasi pada SW1 :

SW1(config)#interface port-channel 1

“no switchport” digunakan karena kita ingin port channel interface dikonfigure menjadi layer 3 interface , dimana kita bisa langsung konfigurasi ip pada interface tersebut.

SW1(config-if)#no switchport

SW1(config-if)#ip address 192.168.1.1 255.255.255.0

SW1(config-if)#interface range fa 0/1 – 3

SW1(config-if-range)#no switchport

SW1(config-if-range)#no ip address

SW1(config-if-range)#channel-group 1 mode desirable

SW1(config-if-range)#end

Check Config Akhir :

SW1#sh etherchannel

Channel-group listing:

———————-

Group: 1

———-

Group state = L3

Ports: 3 Maxports = 8

Port-channels: 1 Max Portchannels = 1

Protocol: PAGP

Konfigurasi pada SW2 :

SW2(config)#interface port-channel 1

SW2(config-if)#no switchport

SW2(config-if)#ip address 192.168.1.2 255.255.255.0

SW2(config-if)#interface range fa0/1 – 3

SW2(config-if-range)#no shut

SW2(config-if-range)#no switchport

SW2(config-if-range)#no ip address

SW2(config-if-range)#channel-group 1 mode auto

SW2(config-if-range)#end

Check Config Akhir :

SW2#show etherchannel

Channel-group listing:

———————-

Group: 1

———-

Group state = L3

Ports: 3 Maxports = 8

Port-channels: 1 Max Portchannels = 1

Protocol: PAGP

Catatan:

Perintah “no switchport” digunakan untuk merubah interface dari mode layer 2 manjadi mode layer 3.

 

 

 

 

Instalasi ASAv di GNS3

INSTALLASI CISCO ASA DI GNS3

Bahan-bahan Software :

1.Cisco ASAv : asav971.qcow2 à Cari di Google atau download di Cisco.com

2.GNS3 Software Versi 1.5.3 à Download di Website GNS3

3.GNS3 VM Versi 1.5.3 à Download di Website GNS3

4.VMWorkstation 12Pro atau Versi Yang Lain .

Step :

1.Pertama yang dilakukan adalah Install VMWorstation Pro.

2.Lanjutkan dengan open file GNS3VM , seperti dibawah ini ,

c.Kemudian setting beberapa variabel yang ada untuk optimasinya sbb :

Note : – Memory harus diberikan sebesar 2Gb untuk performance yang baik , jika bisa lebih besar lebih baik.

3.Install GNS3 1.5.3 Windows di PC atau Laptop anda.

4.Klik Edit – Preference pada Menu GNS3 , Pilih Menu QEMU àQemuVMS

Isikan semua sama seperti pada gambar dibawah ini .

General Setting Config

Untuk tipe console yang saya gunakan nanti di AVAv ini adalah VNC , seperti yang terlihat pada console type diatas.

-HDD Config

Pada HDD Config HDA Primary -àBrowse file “asav971.qcow2 , dan klik “OK”

Biarkan pilihan yang lain secara default saja.

-Network Config

Disini saya hanya menggunakan 4 Adapter ( Ethernet ) Interface yang digunakan di ASA , Jika ingin lebih silakan ganti / tambahkan adapter yang anda inginkan .

-Advanced Config

Pada Advanced Setting ini , pada kotak merah yang saya tandai  Klik “Use as Link Base VM “ digunakan untuk clonning ASAv jika anda gunakan banyak ASAv dalam Lab .

Memulai Lab ASAv :

Drag and drop ASAv yang sudah kita buat tadi , lakukan seperti dalam gambar dibawah ini .

Pada kondisi ini ASAv masih dalam keadaan mati / stop , seperti terlihat dalam gambar dibawah ini .

Kemudian kita hidupkan ASAv yang akan kita gunakan sebagai LAB , dengan cara sbb :

Pada gambar terlihat ada 4 buah interface yang terdapat pada ASAv yang akan kita gunakan sebagai LAB atau untuk belajar.

Waktu kita menghidupkan ASAv, GNS3 akan memanggil GNSvm yang kita install di VMWorkstation

Seperti terlihat digambar ini .

Kemudian , kita lanjutkan ke console ASAv dengan mengklik seperti gambar dibawah ini :

Pilih console VNC sbb :

Setelah booting selesai , maka akan terlihat ASAv yang sudah siap digunakan seperti gambar dibawah ini .

Berikut Contoh LAB yang menggunakan ASA dan Switch

Contoh Command yang bisa dilakukan di ASAv sbb :

Default password pada perintah Enable password pada asav tidak ada , setelah enable langsung enter saja , dan asav siap digunanakan.

Gambar dibawah ini adalah menggunakan perintah “Enable” , dan “show int ip brief” , terlihat ada 4 buah interface yang ada pada asav.

Demikian tuturial cara install ASAv pada GNS3 .

 

Network Design Part III

Bay Face Layout

Jika kita tidak familiar dengan istilah ini , “Bay Face Layout” adalah sebuah diagram atau gambar , bagaimana rak akan dibangun , termasuk semua detailnya. Untuk saya keuntungan terbesar adalah sekali kita buat , kita dapat menyuruh orang lain untuk memasang semua peralatan , jika kita inginkan dengan menggunakan layout tersebut. Dapat saya contohkan “Bay Face Layout” adalah sebagai berikut :

Screen Shot 2014-07-10 at 11.25.18 PM

Power dan System Pendinginan

Ini adalah waktu yg sangat baik untuk melihat kebutuhan daya yang diperlukan. Kebanyakan vendor mendata konsumsi daya untuk semua peralatan yg mereka pakai di website mereka.

Sangat mudah untuk mencari tahu daya yg diperlukan untuk semua peralatan , misalkan AC/DC , Voltage dan Ampere dan konektor yg diperlukan untuk ditambahkan pada masing-masing rak.

Coba bicarakan pada orang yg bertanggung jawab dimana rak tersebut ditempatkan, dan pastikan mereka dapat men-support semua peralatan yg kita tempatkan didalam rak.

Jangan lupakan juga system pendinginan. Bersama dengan spesifikasi tenaga , vendor akan menuliskan nilai BTU ( British Thermal Unit ) untuk peralatan mereka. Orang yg bertanggung jawab pada lingkungan dimana semua peralatan ini dipasang harus tahu semua informasi ini.

Sebagai contoh ,untuk mencari nilai temperature panas devices cisco 6500 switch, coba cari di website cisco dengan kata kunci “6500 power and heat numbers” , karena tenaga dan temperature panas bermacam-macam tergantung pada module yg di pasang, kita harus gambarkan atau tuliskan informasi ini pada masing-masing pemasangan.

Untuk cisco 6509-V-E khusus atau model yg lebih dulu dapat ditunjukkan pada gambar berikut ini.

Screen Shot 2014-07-10 at 2.45.31 PM

Power dan nilai BTU untuk model 6509-V-E.

Harap diingat selalu ada limit seberapa banyak devices yang dapat ditempatkan pada rak.

Dulu kita selalu mencoba untuk memasukkan berapa banyak server pada rack 1U , virtualisasi dan blade server banyak memberikan perubahan drastis , dan banyak perusahaan mengadopsi mereka yang secara radikal mengubah cara kita membangun rak server.

Tips Membuat Network Diagram

Para Engineer tampaknya ingin membuat dokumen mereka begitu rumit , hingga mereka sendiri kadang tidak dapat membacanya.

Berikut berapa tips yang dapat membantu anda menghasilkan dokumentasi yang baik :

1. Buatlah Mudah

Lihatlah berapa contoh gambar yg terdahulu , masing-masing dirancang untuk menyampaikan ide tunggal. Semakin kita mencoba untuk memasukkan dalam sebuah gambar , semakin sulit dimengerti.

2. Pisahkan Ide logika dan Fisik

Konektifitas fisik sangat penting , tapi cobalah untuk tetap terpisah dari VLAN , routing , dan lainnya. Saya ingin membuat dua gambar , satu untuk port fisik dan lain dengan VLAN dan alamat IP.

3. Jangan Menyilangkan Garis

Setiap kali anda menyilangkan garis dalam sebuah gambar , gambar akan sangat sulit dibaca. Kadang-kadang memang tidak dapat dihindari , tetapi cobalah untuk menjaga garis menyeberang ke minimum.

4. Mengarahkan garis lurus anda

Jika kita kumpulkan gambar dimana garis-garis lurus yg sedikit dari horizontal atau vertikal , maka akan terlihat seperti lukisan dari seorang pembunuh berantai. Bila kira meluangkan waktu untuk mengarahkan semua baris , perbedaanya adalah dramatis. Demikian pula , garis yang ditarik pada sudut semua harus pada sudut yg sama sebisa mungkin.

5. Gambarkan ketika anda dapat Menggambarkan

Jika ada 2 lokasi digambar anda , pisahkan entah bagaimana caranya. Letakkan masing-masing di persegi panjang. Menggunakan warna atau bahkan abu-abu dapat membantu juga.

6. Bariskan Ikon Anda

Jika anda memiliki deretan ikon dalam gambar anda , luangkan waktu untuk membariskan mereka semua sepanjang sumbu tunggal.

Penamaan Untuk Devices/Perangkat

Nama host harus dibangun , sehingga siapapun dengan pengetahuan dasar tentang jaringan dapat menentukan fungsi perangkat. Namun, tampaknya ada kecenderungan dikalangan orang-orang IT untuk memberikan perangkat mereka nama yang paling tidak bisa dimengerti mungkin.

Dalam salah satu sesi pelatihan untuk jaringan yang mengandung nama hostname aneh , salah satu peserta ditanya , apakah nama host sangat berarti ? Tidak ada yg bisa menjawab tanpa melihat dokumen yang mejelaskan tata letak hostname. Nama host seharusnya tidak memerlukan penelitian!

Berikut ada rincian dari nama salah satu contoh host :

gadnslax1mai750901

gad = Nama perusahaan ( GAD Technology )

ns = Network Service

lax = Los Angeles

1 = Devices ke 1 yang ada di LA.

Mai = Main Street

7509 = Cisco Devices 7509

01 = Perangkat Cisco 7509 yang ke 1 dilokasi ini.

Kegunaan suatu hostname adalah untuk meng-identifikasi peralatan , hostname harusnya mudah diingat. Ketika hostname susah diingat daripada IP address , menggunakan salah satunya adalah sangat kontraproduktif.

Ketika nama host digabungkan dengan nama Domain untuk membuat nama domain berkualifikasi lengkap ( FQDN ), string yang dihasilkan harus jelas dan sederhana . Contoh sw1.gad.net , adalah FQDN yang sangat sederhana yang menggambarkan switch pertama pada domain gad.net.

Saya suka menggunakan hostname untuk menjelaskan sesuatu fungsi pada perangkat. Wan Router contoh yang sangat baik. Untuk perusahaan yang mempunyai banyak lokasi , penambahan lokasi untuk hostname , contoh LAX-WAN-Router , ini sungguh berguna.

Peralatan biasanya digunakan berpasangan , dalam hal ini juga adalah ide yang baik untuk nomor perangkat , misal : LAX-Wan-Router-1. Menurut saya meskipun nama yang terlalu panjang dan fakta bahwa perangkat router tidak relevan dengan fungsinya ; LAX-WAN-1 akan cukup dimengerti. Atau jika anda akan mengunakan hirarki DNS , WAN-1.lax.domain.com akan cukup baik juga.

Setiap perusahaan mempunyai kebutuhan yang unik , jika anda bekerja di suatu ISP anda mungkin mempunyai perangkat dibanyak pelanggan . Dalam kasus ini termasuk nama pelanggan yang bermanfaat ( misalkan , GAD-WAN-1 ), anda harus menahan diri untuk mendokumentasikan jaringan dengan nama host. Tentu saja , setiap orang memiliki pendapat mereka sendiri tentang nama host, tetapi saran saya adalah , untuk menjaga mereka se-sederhana mungkin.

Setelah anda memiliki nama host , tambahkan juga nama interface ke nama host untuk DNS, misalkan serial 0/0/0:1 pada LAX-WAN-1 akan memiliki nama host DNS dari s0-0-0-lax-wan-1 ( karena DNS hanya dapat menggunakan tanda hubung ). Hal ini membuat perintah Traceroute akan sangat mudah dbaca , karena setiap node dan antar muka IP dalam node diberi label dengan jelas.

Contoh :

[gad]$traceroute switch9.mydomain.com
traceroute to switch9.mydomain.com (10.10.10.10), 30 hops max, 40 byte packets 1 s0-0.router1.mydomain.com 9.854 ms 10.978 ms 11.368 ms
2 f0-1.switch2.mydomain.com 2.340 ms 1.475 ms 1.138 ms
3 g0-0-12.switch9.mydomain.com 1.844 ms 1.430 ms 1.833 ms

Network Design

Saya tidak dapat mengatakan kepada anda , bagaimana seharusnya anda men-desain network anda.

Bagaimanapun juga , menunjukkan kepada anda beberapa contoh perusahaan dan perusahaan e-commerce diluar sana dan menjelaskan bagaimana saya memilih untuk fokus pada design.

Jaringan Perusahaan

Kebanyakan jaringan dirancang dengan model tree tier klasik , model ini memiliki Inti , Distribusi , dan Tingkat Akses. Tingkat ini dengan tegas , dilayani oleh perangkat yang berbeda. Secara tradisional Routing adalah yang sangat lambat, proses yang sangat mahal. Untuk alasan ini , routing dilakukan di Inti , semua tingkat biasanya diaktifkan. Dengan munculnya switch layer 3 yang sangat murah , model tree tier ini mulai runtuh untuk skala jaringan perusahaan. Kita akan melihat model tradisional karena dapat digunakan saat ini , serta beberapa model colaps-core.

Arsitektur Three – Tier

Arsitektur bertingkat tiga ini , paling sering terlihat di buku teks , dan masih banyak digunakan dalam industri. Pemisahan fisik tiga tingkat ini biasanya terjadi ketika ada kebutuhan fisik untuk melakukanya. Sebuah contoh yang baik adalah sebuah Perguruan Tinggi , atau kampus Bisnis : mungkin ada switch inti ( Mungkin ditengah lokasi ) , switch distribusi di setiap bangunan , dan switch penutup akses ke pengguna di setiap bangunan. Yang spesifik tergantung pada tata letak fisik kampus. Gambar dibawah ini , menunjukkan jaringan bertingkat tiga pada perusahaan.

Dibagian bawah gambar , pengguna , printer , telepon IP , dan titik akses nirkabel ( AP ), yang terhubung ke switch akses layer. Akses layer switch dihubungkan ke switch distribusi layer dibarisan tengah. Switch distribusi terhubung ke dua switch , yang merupakan jaringan inti. Internet dan kumpulan server keeduanya terhubung ke dalam jaringan inti.

Screen Shot 2014-07-10 at 11.10.30 PM

Colappse Core – Tidak ada Distribusi

Jaringan colappse core adalah sangat umum , ruangan di gedung-gedung pencakar langit biasanya dilokasikan lantai demi lantai. Kabel biasanya dijalankan dari titik di lantai ke lokasi pusat dilantai yang sama. Lantai biasanya berhubungan dengan saluran yang berjalan antara lantai. Ketika sebuah perusahaan menempati beberapa lantai , kabel dari setiap lantai cocok untuk colappse core , karena ada kemungkinan kabel terbatas antara lantai.

Karena jumlah ruang disetiap lantai terbatas , biasanya ada sedikit kebutuhan untuk lebih dari dua lapisan jaringan fisik. Dengan switch inti di lantai satu dan akses switch dilantai yang tersisa, switch akses dapat bertindak sebagai distribusi layer.

Port density biasanya tidak menjadi issue , dan masing-masing lantai juga tidak banyak mengambil space fisik perangkat. Dari sudut pandang yang logis distribusi layer bisa dikecilkan menjadi core juga. Dan mungkin juga kita tidak membutuhkan distribusi layer. Pada akhirnya semua kembali pada kebutuhan masing-masing perusahaan.

Colappse Core – tanpa Distribusi ataupun Access

collapse-w-distri-or-access.png

Model ini juga sangat populer pada perusahaan yang hanya mempunyai 1 lokasi gedung , dimana mereka hanya mempunyai 1 core Switch. Sebuah perusahaan yang mempunyai banyak karyawan dan berada pada 1 lokasi gedung dan mempunyai ruangan komputer tersendiri untuk memanage semua perangkat.

Sebuah perangkat high density , high availability switch seperti cisco 6509 dapat mendukung ratusan pengguna , seperti gambar dibawah ini .

Colappse Core 1 Layer
Colappse Core 1 Layer

Trunk

Trunk mungkin dibutuhkan dimana kita membutuhkan interkoneksi switch dengan switch lainya. Dan yang harus diingat adalah , dibutuhkan switch access diantara koneksi 2 buah core. Dan bila kita memilih layer 3 design kita akan membutuhkan beberapa trunk.

Ether Channel

Ether Channel adalah menggabungkan 2 buah kabel/koneksi menjadi satu , dan dapat meningkatkan ketahanan dan bandwidth antar switch. Tergantung dari kebutuhan network anda , kita dapat membundle 2 , 3 atau 4 kabel terserah kepada anda.

Server Anda mungkin membutuhkan Ether Channel , coba komunikasikan dengan team anda , dan jika membutuhkan anda tau cara configurasinya.

vPC ( Virtual Port Channel ) dapat menjangkau banyak devices dengan menggunakan Nexus Switch, sama dengan versi 6500 Vss dapat mensupport Multichassis Ether Channel ( MEC ).

Spanning Tree

Tergantung port mana yang akan digunakan sebagai port untuk user atau server , port tersebut dapat diconfigurasi menjadi “spanning-tree portfast”. Konfigurasikan satu antara core switch menjadi spanning tree root bridge dan core switch yang lain menjadi secondary root bridge.

VTP

VTP ( Virtual Trunking Protocol ) dibutuhkan untuk konfigurasi VTP domain name , dan Trunk negosiasi dibutuhkan VTP domain.

VLAN

Seberapa banyak VLAN yang anda butuhkan ? pastikan anda merencanakan kebutuhanya dengan baik. Berikut ini beberapa contoh :

  • Internet
  • Server Farm
  • User Vlan
  • dll

Rencanakan di depan , akan menghemat waktu anda untuk membangun sebuah network yang berkualitas tanpa membuang-buang waktu.